Think about updating your browser

You are using a former version of Internet Explorer. A huge amount of websites don’t support Internet Explorer 6 anymore and you could not access to those sites before the update of your browser.

You’re unsure?

Visit the Microsoft support page.

This site remains viewable but is still less optimale comparated to the use with a recent browser.

Utilities Menu Catalog Benefits

Javascript is not active!
You must activate it to order.

Refresh the page


First empire shoes, for troop or civilians , supplied with buckles

  1. From 105,00 €

    Order

All leather, better finished than before

Customers who bought this item also bought


top